debian/patches: Drop 0001-Switch-to-Ayatana-AppIndicator.patch. Applied upstream.
This commit is contained in:
parent
5ebffc7074
commit
b99a8a39e6
@ -1,60 +0,0 @@
|
||||
From ee0aeae33e0218100369f830e9a0484c89d36442 Mon Sep 17 00:00:00 2001
|
||||
From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
|
||||
Date: Thu, 29 Mar 2018 13:04:17 +0200
|
||||
Subject: [PATCH 1/2] Switch to Ayatana AppIndicator.
|
||||
|
||||
---
|
||||
configure.ac | 8 ++++----
|
||||
src/main.c | 2 +-
|
||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index cec96f2..4d10117 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -146,10 +146,10 @@ AC_ARG_ENABLE([accountsservice],
|
||||
AM_CONDITIONAL([HAVE_ACCOUNTSSERVICE], [test "x$enable_accountsservice" = xyes])
|
||||
|
||||
# Application indicator
|
||||
-APPINDICATOR_PKG=appindicator3-0.1
|
||||
+APPINDICATOR_PKG=ayatana-appindicator3-0.1
|
||||
|
||||
AC_ARG_ENABLE([appindicator],
|
||||
- AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for application indicators]),
|
||||
+ AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for Ayatana AppIndicators]),
|
||||
[enable_appindicator=$enableval],
|
||||
[enable_appindicator="auto"])
|
||||
|
||||
@@ -163,7 +163,7 @@ fi
|
||||
if test "x$enable_appindicator" = "xyes"; then
|
||||
PKG_CHECK_MODULES(APPINDICATOR,
|
||||
[$APPINDICATOR_PKG >= $APPINDICATOR_REQUIRED],
|
||||
- [AC_DEFINE(HAVE_APPINDICATOR, 1, [Have AppIndicator])])
|
||||
+ [AC_DEFINE(HAVE_APPINDICATOR, 1, [Have Ayatana AppIndicator])])
|
||||
fi
|
||||
|
||||
AM_CONDITIONAL(HAVE_APPINDICATOR, test "x$enable_appindicator" = "xyes")
|
||||
@@ -214,6 +214,6 @@ echo "
|
||||
cppflags: ${CPPFLAGS}
|
||||
|
||||
Accountsservice: ${enable_accountsservice}
|
||||
- Application indicator: ${enable_appindicator}
|
||||
+ Ayatana AppIndicator: ${enable_appindicator}
|
||||
Maintainer mode: ${USE_MAINTAINER_MODE}
|
||||
"
|
||||
diff --git a/src/main.c b/src/main.c
|
||||
index 68f34ef..76bd958 100644
|
||||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -30,7 +30,7 @@
|
||||
#include <polkitagent/polkitagent.h>
|
||||
|
||||
#ifdef HAVE_APPINDICATOR
|
||||
-#include <libappindicator/app-indicator.h>
|
||||
+#include <libayatana-appindicator/app-indicator.h>
|
||||
#endif
|
||||
|
||||
#include "polkitmatelistener.h"
|
||||
--
|
||||
2.11.0
|
||||
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
@ -1 +0,0 @@
|
||||
0001-Switch-to-Ayatana-AppIndicator.patch
|
Loading…
Reference in New Issue
Block a user