35 lines
896 B
Makefile
Executable File
35 lines
896 B
Makefile
Executable File
#!/usr/bin/make -f
|
|
|
|
DHFLAGS=--parallel
|
|
|
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
|
|
DPKG_EXPORT_BUILDFLAGS = 1
|
|
include /usr/share/dpkg/buildflags.mk
|
|
|
|
%:
|
|
dh $@ $(DHFLAGS) --with gir --without autoreconf
|
|
|
|
override_dh_missing:
|
|
dh_missing --fail-missing
|
|
|
|
override_dh_install:
|
|
rm -f debian/tmp/usr/lib/*/*.la
|
|
mkdir -p debian/tmp/usr/share/doc/libmate-desktop-doc/
|
|
mv debian/tmp/usr/share/gtk-doc/html/mate-desktop debian/tmp/usr/share/doc/libmate-desktop-doc/html
|
|
dh_install
|
|
|
|
override_dh_installchangelogs:
|
|
dh_installchangelogs NEWS
|
|
|
|
override_dh_auto_configure:
|
|
# upstream tarball is without configure. autogen.sh will create it
|
|
NOCONFIGURE=1 ./autogen.sh
|
|
dh_auto_configure $(DHFLAGS) -- \
|
|
--disable-silent-rules \
|
|
--disable-static \
|
|
--disable-schemas-compile \
|
|
--enable-gtk-doc
|
|
|
|
get-orig-source:
|
|
uscan --noconf --force-download --rename --download-current-version --destdir=..
|