debian/patches/070_revert-widget-set-up-signals-after-initializing.patch:
This patch was a temporary workaround for a bug in mutter which has been fixed in version 3.4. It was not supposed to be shipped as part of wheezy, so drop it again.
This commit is contained in:
parent
ba6ec6492a
commit
da79680fd4
4
debian/changelog
vendored
4
debian/changelog
vendored
@ -11,6 +11,10 @@ gtk+3.0 (3.4.2-4) UNRELEASED; urgency=low
|
|||||||
* debian/patches/073_transparent_colors.patch: Handle transparent colors
|
* debian/patches/073_transparent_colors.patch: Handle transparent colors
|
||||||
better in GtkStyle emulation. Patch cherry-picked from upstream Git.
|
better in GtkStyle emulation. Patch cherry-picked from upstream Git.
|
||||||
Closes: #669694
|
Closes: #669694
|
||||||
|
* debian/patches/070_revert-widget-set-up-signals-after-initializing.patch:
|
||||||
|
This patch was a temporary workaround for a bug in mutter which has been
|
||||||
|
fixed in version 3.4. It was not supposed to be shipped as part of wheezy,
|
||||||
|
so drop it again.
|
||||||
|
|
||||||
-- Michael Biebl <biebl@debian.org> Mon, 06 Aug 2012 18:00:10 +0200
|
-- Michael Biebl <biebl@debian.org> Mon, 06 Aug 2012 18:00:10 +0200
|
||||||
|
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
From 502d6cb9bc75370ed0692849c65c89d52e818a96 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Biebl <biebl@debian.org>
|
|
||||||
Date: Wed, 28 Mar 2012 06:10:17 +0200
|
|
||||||
Subject: [PATCH] Revert "widget: Set up signals after initializing style
|
|
||||||
context"
|
|
||||||
|
|
||||||
This reverts commit 5d579811843f81db9866ac81afc5297f776cfb3b.
|
|
||||||
|
|
||||||
This change breaks the window decorations in gnome-shell resp. mutter 3.2.
|
|
||||||
It can be dropped again, once GNOME 3.4 is in unstable.
|
|
||||||
---
|
|
||||||
gtk/gtkwidget.c | 6 +++---
|
|
||||||
1 files changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
Index: gtk+-3.4.1/gtk/gtkwidget.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk+-3.4.1.orig/gtk/gtkwidget.c 2012-04-13 02:31:42.000000000 +0200
|
|
||||||
+++ gtk+-3.4.1/gtk/gtkwidget.c 2012-04-15 20:55:33.278308259 +0200
|
|
||||||
@@ -14119,6 +14119,9 @@
|
|
||||||
|
|
||||||
gtk_style_context_set_direction (priv->context, gtk_widget_get_direction (widget));
|
|
||||||
|
|
||||||
+ g_signal_connect (widget->priv->context, "changed",
|
|
||||||
+ G_CALLBACK (style_context_changed), widget);
|
|
||||||
+
|
|
||||||
screen = gtk_widget_get_screen (widget);
|
|
||||||
if (screen)
|
|
||||||
gtk_style_context_set_screen (priv->context, screen);
|
|
||||||
@@ -14127,9 +14130,6 @@
|
|
||||||
if (priv->parent)
|
|
||||||
gtk_style_context_set_parent (priv->context,
|
|
||||||
gtk_widget_get_style_context (priv->parent));
|
|
||||||
-
|
|
||||||
- g_signal_connect (widget->priv->context, "changed",
|
|
||||||
- G_CALLBACK (style_context_changed), widget);
|
|
||||||
}
|
|
||||||
|
|
||||||
return widget->priv->context;
|
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
@ -8,7 +8,6 @@
|
|||||||
044_tracker_fts.patch
|
044_tracker_fts.patch
|
||||||
060_ignore-random-icons.patch
|
060_ignore-random-icons.patch
|
||||||
061_multiarch_module_fallback.patch
|
061_multiarch_module_fallback.patch
|
||||||
070_revert-widget-set-up-signals-after-initializing.patch
|
|
||||||
071_fix-installation-of-HTML-images.patch
|
071_fix-installation-of-HTML-images.patch
|
||||||
072_statusicon_icon_size.patch
|
072_statusicon_icon_size.patch
|
||||||
073_transparent_colors.patch
|
073_transparent_colors.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user