Remove obsolete gtk-update-icon-cache package, now built by gtk4
This commit is contained in:
parent
a83827b113
commit
ac309bfb0c
18
debian/control
vendored
18
debian/control
vendored
@ -255,24 +255,6 @@ Description: GTK graphical user interface library -- gir bindings
|
|||||||
This package can be used by other packages using the GIRepository format to
|
This package can be used by other packages using the GIRepository format to
|
||||||
generate dynamic bindings.
|
generate dynamic bindings.
|
||||||
|
|
||||||
Package: gtk-update-icon-cache
|
|
||||||
Section: misc
|
|
||||||
Architecture: any
|
|
||||||
Multi-Arch: foreign
|
|
||||||
Depends: ${misc:Depends},
|
|
||||||
${shlibs:Depends}
|
|
||||||
Breaks: libgtk-3-bin (<< 3.20.6-1),
|
|
||||||
libgtk2.0-bin (<< 2.24.30-2)
|
|
||||||
Replaces: libgtk-3-bin (<< 3.20.6-1),
|
|
||||||
libgtk2.0-bin (<< 2.24.30-2)
|
|
||||||
Description: icon theme caching utility
|
|
||||||
gtk-update-icon-cache creates mmap()able cache files for icon themes.
|
|
||||||
.
|
|
||||||
GTK can use the cache files created by gtk-update-icon-cache to avoid a lot
|
|
||||||
of system call and disk seek overhead when the application starts. Since the
|
|
||||||
format of the cache files allows them to be mmap()ed shared between multiple
|
|
||||||
applications, the overall memory consumption is reduced as well.
|
|
||||||
|
|
||||||
Package: libgail-3-0t64
|
Package: libgail-3-0t64
|
||||||
Provides: ${t64:Provides}
|
Provides: ${t64:Provides}
|
||||||
Replaces: libgail-3-0 (<< 3.24.41-1.1)
|
Replaces: libgail-3-0 (<< 3.24.41-1.1)
|
||||||
|
2
debian/gtk-update-icon-cache.install
vendored
2
debian/gtk-update-icon-cache.install
vendored
@ -1,2 +0,0 @@
|
|||||||
../../../debian/update-icon-caches usr/sbin/
|
|
||||||
usr/bin/gtk-update-icon-cache
|
|
@ -1 +1,2 @@
|
|||||||
|
usr/bin/gtk-update-icon-cache
|
||||||
usr/share/man/man1/gtk-update-icon-cache.1
|
usr/share/man/man1/gtk-update-icon-cache.1
|
34
debian/patches/060_ignore-random-icons.patch
vendored
34
debian/patches/060_ignore-random-icons.patch
vendored
@ -1,34 +0,0 @@
|
|||||||
From: Loic Minier <lool@dooz.org>
|
|
||||||
Date: Sun, 21 Oct 2007 22:05:42 +0200
|
|
||||||
Subject: Don't list images from unknown directories in icon cache
|
|
||||||
|
|
||||||
After GTK 2.12.0, gtk-update-icon-cache fails if there is a PNG file
|
|
||||||
placed directly in /usr/share/icons/hicolor (not in a correct
|
|
||||||
subdirectory like 48x48/apps).
|
|
||||||
|
|
||||||
TODO: This is believed to have been fixed differently upstream, so maybe
|
|
||||||
this change is no longer necessary:
|
|
||||||
"I believe a slightly different fix that I did some time ago fixes this
|
|
||||||
too." --Matthias Clasen, 2008-02-16 04:43:10 UTC
|
|
||||||
|
|
||||||
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=451634
|
|
||||||
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=444285
|
|
||||||
Forwarded: yes
|
|
||||||
Applied-upstream: no
|
|
||||||
---
|
|
||||||
gtk/updateiconcache.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/gtk/updateiconcache.c b/gtk/updateiconcache.c
|
|
||||||
index 37f9b4f..52853dd 100644
|
|
||||||
--- a/gtk/updateiconcache.c
|
|
||||||
+++ b/gtk/updateiconcache.c
|
|
||||||
@@ -689,7 +689,7 @@ scan_directory (const gchar *base_path,
|
|
||||||
directories = g_list_append (directories, g_strdup (subdir));
|
|
||||||
}
|
|
||||||
else
|
|
||||||
- dir_index = 0xffff;
|
|
||||||
+ continue;
|
|
||||||
}
|
|
||||||
|
|
||||||
image = g_new0 (Image, 1);
|
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
@ -1,5 +1,4 @@
|
|||||||
016_no_offscreen_widgets_grabbing.patch
|
016_no_offscreen_widgets_grabbing.patch
|
||||||
017_no_offscreen_device_grabbing.patch
|
017_no_offscreen_device_grabbing.patch
|
||||||
060_ignore-random-icons.patch
|
|
||||||
reftest_compare_surfaces-Report-how-much-the-images-diffe.patch
|
reftest_compare_surfaces-Report-how-much-the-images-diffe.patch
|
||||||
reftests-Allow-minor-differences-to-be-tolerated.patch
|
reftests-Allow-minor-differences-to-be-tolerated.patch
|
||||||
|
26
debian/update-icon-caches
vendored
26
debian/update-icon-caches
vendored
@ -1,26 +0,0 @@
|
|||||||
#!/bin/sh
|
|
||||||
|
|
||||||
case "$1" in
|
|
||||||
""|-h|--help)
|
|
||||||
echo "Usage: $0 directory [ ... ]"
|
|
||||||
exit 1
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
for dir in "$@"; do
|
|
||||||
if [ ! -d "$dir" ]; then
|
|
||||||
continue
|
|
||||||
fi
|
|
||||||
if [ -f "$dir"/index.theme ]; then
|
|
||||||
# Generate or regenerate the cache
|
|
||||||
if ! gtk-update-icon-cache --force --quiet "$dir"; then
|
|
||||||
echo "WARNING: icon cache generation failed for $dir"
|
|
||||||
fi
|
|
||||||
else
|
|
||||||
# No more index.theme, remove the cache if it exists
|
|
||||||
rm -f "$dir"/icon-theme.cache
|
|
||||||
rmdir -p --ignore-fail-on-non-empty "$dir"
|
|
||||||
fi
|
|
||||||
done
|
|
||||||
|
|
||||||
exit 0
|
|
19
debian/update-icon-caches.8
vendored
19
debian/update-icon-caches.8
vendored
@ -1,19 +0,0 @@
|
|||||||
.TH UPDATE-ICON-CACHES 8 "13 July 2007"
|
|
||||||
.SH NAME
|
|
||||||
update-icon-caches \- Update wrapper script for the icon caches
|
|
||||||
.SH SYNOPSIS
|
|
||||||
\fBupdate-icon-caches\fP \fIdirectory\fP [ \fI...\fP ]
|
|
||||||
.SH DESCRIPTION
|
|
||||||
\fBupdate-icon-caches\fP is a wrapper script for updating the icon
|
|
||||||
caches in a list of directories.
|
|
||||||
.P
|
|
||||||
In each of the directories passed as arguments, the icon cache is
|
|
||||||
updated if it is already present. It is not created if it does not
|
|
||||||
already exist.
|
|
||||||
.P
|
|
||||||
If the theme index file is not present, the icon cache is removed.
|
|
||||||
.SH SEE ALSO
|
|
||||||
.BR gtk-update-icon-cache (1)
|
|
||||||
.SH AUTHOR
|
|
||||||
This manual page was written by Josselin Mouette <joss@debian.org>,
|
|
||||||
for the Debian GNU/Linux system.
|
|
Loading…
Reference in New Issue
Block a user