Add patch to fix build with gcc-14.

This commit is contained in:
Jaimos Skriletz 2024-07-25 11:34:48 -06:00
parent f7bd09ea19
commit 6a32c3188b
3 changed files with 31 additions and 0 deletions

1
debian/changelog vendored
View File

@ -4,6 +4,7 @@ fvwm (1:2.7.0-3) unstable; urgency=medium
- Update comment for how x-window-manager priority is computed.
* Update debian/copyright to state correct licesens.
* Update obsolete depends.
* Add patch to fix build with gcc-14. Closes: #1074974
-- Jaimos Skriletz <jaimosskriletz@gmail.com> Thu, 25 Jul 2024 11:07:17 -0600

View File

@ -0,0 +1,29 @@
Description: Remove -Werror check which fails in gcc-14.
This fixes #1074974 by removing the unneeded check which fails
when building with gcc-14.
Author: Thomas Adam <thomas@fvwm.org>
Forwarded: https://github.com/fvwmorg/fvwm/pull/106
Debian-Bug: https://bugs.debian.org/1074974
Last-Update: 2024-07-25
diff --git a/configure.ac b/configure.ac
index 97ab9e7a1..a5452e152 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,17 +218,6 @@ fi
AC_ISC_POSIX
AC_MINIX
-# catch -Werror and similar options when running configure
-AC_TRY_COMPILE([#include <stdio.h>],
-[int i; static j; int *p; char *c;
- switch (*p = p = *c) { case 0: printf("%Q", c, p); }
- *c = &i; c = p;
- while (1 || (unsigned int)3 >= 0 || ((int)-1) == ((unsigned int)1));
-], , AC_MSG_ERROR("
-configure is not able to compile programs with warnings. Please
-remove all offending options like -Werror from the CFLAGS and
-CPPFLAGS variables and run configure again."))
-
# check size of some types
ac_save_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $X_CFLAGS"

View File

@ -3,3 +3,4 @@ xthread_fix.patch
fix-hardcoded-xterm.patch
default-config-fvwm2.patch
spelling-error-fix.patch
remove-Werror-check.patch